기본적인 문제는 문제풀이 없이 Solution만 작성되어 있습니다.
Title
Description
자연수 N이 주어졌을 때, 1부터 N까지 한 줄에 하나씩 출력하는 프로그램을 작성하시오.
[ Example Input ]
첫째 줄에 100,000보다 작거나 같은 자연수 N이 주어진다.
5
[ Example Output ]
첫째 줄부터 N번째 줄 까지 차례대로 출력한다.
1
2
3
4
5
Point
readline 모듈을 사용하는 경우 시간 초과...?
이 경우에는 readline 모듈을 사용할때 toString() 메서드를 사용하지 않았는지 확인해보자.
실험해본 결과 ( fs 모듈은 해당하지 않음 )
input = line.toString().split(' ') // => 시간 초과 실패
input = line.split(' ') // => 통과
임을 확인할 수 있었다.
fs 모듈
const fs = require('fs');
const input = fs.readFileSync('/dev/stdin').toString().split(' ')
const RANGE_VALUE = Number(input)
...
readline 모듈
const readline = require('readline');
const rl = readline.createInterface({
input: process.stdin,
output: process.stdout
});
let input = [];
rl.on('line', function (line) {
input = line.split(' ')
}).on('close', function () {
const RANGE_VALUE = Number(input[0])
...
process.exit();
});
Solution
const fs = require('fs');
const input = fs.readFileSync('/dev/stdin').toString().split(' ')
const RANGE_VALUE = Number(input)
for(let i=1; i<=RANGE_VALUE; i++){
console.log(i)
}
글 읽어주셔서 감사합니다.
보다 유익한 컨텐츠를 제작할 수 있도록 노력하겠습니다.
- TLOWAC 이창훈 -
반응형
'알고리즘 > 백준' 카테고리의 다른 글
[백준] javascript - 2742번 : 기찍 N (0) | 2020.07.27 |
---|---|
[백준] javascript - 2739번 : 구구단 (0) | 2020.07.25 |
[백준] javascript - 14681번 : 사분면 고르기 (0) | 2020.07.24 |
[백준] javascript - 2753번 : 윤년 (0) | 2020.07.23 |
[백준] javascript - 9498번 : 시험 성적 (0) | 2020.07.22 |
댓글